Logo

BT600 Low Audio Quality

SOLVED
theworldsbiggestkevin
Occasional Visitor

BT600 Low Audio Quality

Hello,

 

I'm using a Voyager Focus UC headset with a BT600 USB adapter on an HP ZBook Firefly G8 running Windows 11.

 

Both headset and USB adapter have been updated to the latest available firmware via Plantronics Hub.

 

The audio quality when connecting via the BT600 is so incredibly low, however if I pair the headset directly to the laptop using Bluetooth, the quality is noticeably better.

 

I've tried looking for updated BT600 drivers, but I can't seem to locate anything. The BT600 driver appears to be issued by Microsoft, with version 10.0.22000.1. I have also had a poke around in Plantronics Hub but can't seem to see anything related to audio quality.

 

Is anybody able to offer any help with this one?

 

Thanks.

Message 1 of 3
1 ACCEPTED SOLUTION

Accepted Solutions
bhupender
Polycom Employee & Community Manager

Re: BT600 Low Audio Quality

Hello @theworldsbiggestkevin ,

 

 Welcome to Poly Community.

 

Your post lacks basic minimum details so we urge to include these details before posting your query.  As a starter we advise to test your headset+BT600 on another PC and check are you able to reproduce the same issue? In case it is just limited to your PC then you need to check your audio drivers as we do not provide/develop USB drivers for headsets. They all are native to your OS. So these drivers will be loaded automatically by your OS when any USB audio device is plugged. But there is  a known bug with Intel SST driver on Intel 11th Gen PC's which may impact your audio experience with USB devices so you you can refer to this link and see if it helps. If  issue is noticed with other computers too then this needs to be investigated and suggest you to log a ticket for this. Troubleshooting or providing support via the community is outside the scope for myself as a Poly employee.
 
 Please raise a ticket with Poly Technical Support.


 Please remember, if you see a post that helped you, and it answers your question, please mark it as an "Accept as Solution".
 
This forum reply, or post is based upon my personal experience and does not reflect the opinion or view of my employer. Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.

 

Best Regards,


Bhupender

View solution in original post

Message 2 of 3
2 REPLIES 2
bhupender
Polycom Employee & Community Manager

Re: BT600 Low Audio Quality

Hello @theworldsbiggestkevin ,

 

 Welcome to Poly Community.

 

Your post lacks basic minimum details so we urge to include these details before posting your query.  As a starter we advise to test your headset+BT600 on another PC and check are you able to reproduce the same issue? In case it is just limited to your PC then you need to check your audio drivers as we do not provide/develop USB drivers for headsets. They all are native to your OS. So these drivers will be loaded automatically by your OS when any USB audio device is plugged. But there is  a known bug with Intel SST driver on Intel 11th Gen PC's which may impact your audio experience with USB devices so you you can refer to this link and see if it helps. If  issue is noticed with other computers too then this needs to be investigated and suggest you to log a ticket for this. Troubleshooting or providing support via the community is outside the scope for myself as a Poly employee.
 
 Please raise a ticket with Poly Technical Support.


 Please remember, if you see a post that helped you, and it answers your question, please mark it as an "Accept as Solution".
 
This forum reply, or post is based upon my personal experience and does not reflect the opinion or view of my employer. Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.

 

Best Regards,


Bhupender

Message 2 of 3
theworldsbiggestkevin
Occasional Visitor

Re: BT600 Low Audio Quality

Hi Bhupender,

 

I am using an 11th generation Intel processor (i5-1135G7) and disabling the 'Intel Smart Sound Technology for USB Audio' device, as described in the article that you linked has resolved the issue.

 

Thanks for your assistance, it is much appreciated.

Message 3 of 3