ip450 doesn't load MAC-directory

Occasional Contributor

ip450 doesn't load MAC-directory

For the life of me I cannot get any of our organization's IP450s to load a directory file from our provisioning server. Except when they first register with the server they will download 000000000000-directory.xml.


I have 25 phones who need their directory updated and cannot get them to pull the file. They happily pull the other cfg files and even updated their bootrom and firmware. But they simply refuse to load the directory file.


I've tried <MAC>-directory.cfg

I've tried <MAC>-directory.xml

I've tried symbolically linking <MAC>-directory.cfg (and .xml) to our 000000000000-directory


After each change I force a reboot of the phone to test it. Nothing changes, the phone's contact directory remains unchanged.


Any ideas?


I cringe at configuring each phone by hand through their web interface each time we need to change something. It also doesn't seem to be the right way to handle a central provisioned phone system either.


Thanks in advance,



Message 1 of 5
Frequent Advisor

Re: ip450 doesn't load MAC-directory

Check your 000000000000.cfg or <MAC>.cfg file to see if contacts are expected to be in another directory?


Failing that, check your FTP server logs to see what files it's trying to pull.

Message 2 of 5
Polycom Employee & Community Manager

Re: ip450 doesn't load MAC-directory

Hello cfapress,

welcome to the Polycom Community.

As you already noticed the 0000000000000-directory.xml is only loaded on the first boot.


Most likely your provisioning infrastructure is preventing the file <mac>-directory.xml from being used.


Miken32 already suggested a few things so you have a point to start looking.


Best in addition to use the latest Software available as you have failed posting what your current version is.

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services


If official support is required please check how to phone or open a case here

The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.


Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 3 of 5
Occasional Contributor

Re: ip450 doesn't load MAC-directory

Thank you for the suggestions.


Indeed the trouble was the <mac>.cfg file was looking for the directory in a different folder. Now that I know, I've created a symbolic link from the folder the phone expects to our organizations directory.xml.


For example:


The phone is looking for /tftp/polycom/contacts/<mac>-directory.xml

The orgs directory is /tftp/org-directory.xml


So, I created the symlink


ln -s /tftp/org-directory.xml /tftp/polycom/contacts/<mac>-directory.xml


And all works well now.





Message 4 of 5

Re: ip450 doesn't load MAC-directory

Yeah, I'm having the same issue only it isnt a path problem.



Perfect and verified working on my local test phone



The remote phone reboots, and ftp log verify the directory uploaded.



no dice

Message 5 of 5