VVX phones not properly installing certificate sent from Bicom SIP configuration settings

luisg4507
Occasional Visitor

VVX phones not properly installing certificate sent from Bicom SIP configuration settings

We are using VVX 400, 410, 500 and 600 phones and are using TLS.  When provisioning a new phone, all configuration imports as expected except for the certificate being pushed from our SIP server.  The cert does show in the cfg file that gets generated by them (Bicom).  If we upload the exact same configuration in the phone's UI, it works as expected and then any configuration changes from Bicom reflect on the phone thereafter.

 

Weird thing is if we factory reset the phone (which should clear all settings), it will provision and pull all settings, even the certificate, from Bicom as expected.  It is only happening on the very first provisioning.

 

All of our phones are running UC version: 5.9.7.3480

 

Part of the log from the phone:

1230123132|so |4|00|[soMainWriteBootProvProxies] Provisioning proxy resolve state '0'
1230123133|copy |*|00|Server 'sip.oacys.com' said 'prov/0004f2d5214a-app.log' is not present
1230123133|copy |4|00|Could not set the custom header Content-Range for HTTP/s request. Head request failed to get content-length of server file.
1230123135|app1 |5|00|AppExchangeUiC::configSecurity CA path:[/ffs0/ca4.crt]
1230123141|app1 |5|00|AppPhoneLockC::Init - bPhoneLockState [0]
1230123223|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123223|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123223|sip |4|00|MakeTlsConnection: connection failed error -1
1230123223|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123312|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123312|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123312|sip |4|00|MakeTlsConnection: connection failed error -1
1230123312|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123409|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123409|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123409|sip |4|00|MakeTlsConnection: connection failed error -1
1230123409|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123453|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123453|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123453|sip |4|00|MakeTlsConnection: connection failed error -1
1230123453|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123525|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123525|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123525|sip |4|00|MakeTlsConnection: connection failed error -1
1230123525|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123606|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123606|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123606|sip |4|00|MakeTlsConnection: connection failed error -1
1230123606|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123658|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123658|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123658|sip |4|00|MakeTlsConnection: connection failed error -1
1230123658|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123738|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123738|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123738|sip |4|00|MakeTlsConnection: connection failed error -1
1230123738|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123826|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123826|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123826|sip |4|00|MakeTlsConnection: connection failed error -1
1230123826|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230123924|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230123924|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230123924|sip |4|00|MakeTlsConnection: connection failed error -1
1230123924|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230124003|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230124003|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230124003|sip |4|00|MakeTlsConnection: connection failed error -1
1230124003|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230124044|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230124044|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230124044|sip |4|00|MakeTlsConnection: connection failed error -1
1230124044|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230124124|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230124124|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230124124|sip |4|00|MakeTlsConnection: connection failed error -1
1230124124|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
1230124214|sip |4|00|[cert_verify_callback,tcp]:Server certificate verification failed, Untrusted Certificate,error=20
1230124214|sip |4|00|MakeTlsConnection: SSL_connect error 1
1230124214|sip |4|00|MakeTlsConnection: connection failed error -1
1230124214|pps |4|00|[PpsHybridC::OnEvSipOnFetchRootCert] m_lineIdx[1], m_stsuri[], m_username[], m_domain[]
Message 1 of 4
3 REPLIES 3
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX phones not properly installing certificate sent from Bicom SIP configuration settings

Hello @luisg4507  ,

Your post ended up in the Spam Filter so it was released manually. 


Both the communities Must Read First or Read 1st and if available the FAQ reference the basic minimum information a new or follow up post should contain.

This ensures the questions having to be asked are limited and any new or follow up post contains the right amount of details to ensure any voluntary participant within the community does not spend additional time chasing basic information.


Unfortunately, your post fell a bit short of the above-explained requirements and we kindly ask you, therefore, to ensure to read these sections and ensure a reply (not Edit!) provides as much detail as possible


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 4
luisg4507
Occasional Visitor

Re: VVX phones not properly installing certificate sent from Bicom SIP configuration settings

Could you link which FAQ I would need to read specifically?  I found a few but none regarding vvx phones.  As mentioned this is happening on VVX 400, 410, 500 and 600 all running UC version: 5.9.7.3480.

 

When provisioning a new phone, all configuration imports as expected except for the certificate being pushed from our SIP server.  The cert does show in the cfg file that gets generated by them (Bicom).  If we upload the exact same configuration in the phone's UI, it works as expected and then any configuration changes from Bicom reflect on the phone thereafter.

 

Weird thing is if we factory reset the phone (which should clear all settings), it will provision and pull all settings, even the certificate, from Bicom as expected.  It is only happening on the very first provisioning.

Message 3 of 4
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX phones not properly installing certificate sent from Bicom SIP configuration settings

Hello @luisg4507 ,

 

for example these:

 

SteffenBaierUK_0-1640934315704.png

 

The above explains what minimum information a basic post should contain. They also hold several sections explaining simple tasks. It also mentions what files should be included in a post and/or to use the search function. Simply look at the Provisioning FAQ pretty much the first FAQ ever created.

 

Your post does not contain any backup files or complete logs. Only what you decided to share with us, volunteers.

 

Have you yet contacted your service provider who I assume does Poly VVX provisioning on a regular basis? Have you compared a backup prior to provisioning and then after provisioning? A simple tool like Notepad++ with the compare plug-in goes a long way. Also, comparing this with a backup of your attempt?

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 4