VVX 310 Lync cannot connect to Exchange UM 2013 for VM

SOLVED
Cwebb
Advisor

VVX 310 Lync cannot connect to Exchange UM 2013 for VM

Hey All,

 

I have a crazy issue going on here with Polycom VVX phones getting routed to VM sometimes. Long story short, I have narrowed it down to the phones not sending the correct HOST TYP SIP candidate. Both users are internal homed on the same Lync FE server.

 

A trace, when it works looks like this:

 

o=Eyeball 1802354344 2686566346 IN IP4 10.0.1.214
s=Eyeball AnyFirewall Engine Apr 18 2014
c=IN IP4 10.0.1.214
t=0 0
a=ice-pwd:tyDNruy8kSbpAmJCcnI5Oiti
a=ice-ufrag:0dy7
m=audio 2236 RTP/AVP 0
a=candidate:1 1 UDP 2130706431 10.0.1.214 2236 typ host
a=candidate:1 2 UDP 2130706430 10.0.1.214 2237 typ host
a=candidate:2 1 TCP-PASS 6619135 AVPUBLICIP 54336 typ relay raddr 10.0.1.214 rport 47187
a=candidate:2 2 TCP-PASS 6619134 AVPUBLICIP 54336 typ relay raddr 10.0.1.214

 

When it fails, the trace looks like this:

 

o=Eyeball 3066605635 2741368237 IN IP4 192.168.1.20
s=Eyeball AnyFirewall Engine Apr 18 2014
c=IN IP4 192.168.1.20
t=0 0
a=ice-pwd:tyDNruy8kSbpAmJCcnI5Oiti
a=ice-ufrag:0dy7
m=audio 54858 RTP/AVP 0
a=candidate:3 1 UDP 1862270975 192.168.1.20 54858 typ prflx raddr AVPUBLICIP rport 54858
a=candidate:3 2 UDP 1862270974 192.168.1.20 50642 typ prflx raddr AVPUBLICIP rport 50642
a=rtcp:50642
a=remote-candidates:1 172.20.20.11 49154 2 172.20.20.11 49155

 

Notice in the broken trace, my phone tells exchange to connect to the phone via 192.168.1.20. This is the private internal IP Address for our Lync Edge A/V interface that is nated to AVPUBLICIP above.

 

Again both of these users are internal on the same Lync FE pool.

 

Any idea here?

 

Message 1 of 7
1 ACCEPTED SOLUTION

Accepted Solutions
Cwebb
Advisor

Re: VVX 310 Lync cannot connect to Exchange UM 2013 for VM

Polycom has provided another test build, and this time everything is working. We are awaiting a build that can be loaded onto production phones.

 

If anyone else has this issue, please contact Polycom support for a hot fix. 

View solution in original post

Message 7 of 7
6 REPLIES 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: VVX 310 Lync cannot connect to Exchange UM 2013 for VM

Hello Curtis,

welcome back to the Polycom Community.

It is always useful to include the currently used software version as issue experienced may already be addressed in a newer release. This also allows yourself and others to check against current software release notes.

Please be aware of the following when utilizing UCS 4.1.0 or later:

The use of Polycom UC Software versions 4.1.X (“Software”) requires the purchase of a separate Software license for every device that will use the Software in a Lync environment. You may not install, access, or use the Software in a Lync environment on more devices than are listed on your license until additional licenses have been purchased and authorized by Polycom. These licenses should be purchased from the same company from which you purchased the devices. You may operate devices against a Lync server for trial purposes for up to 30 days without purchasing a license. Use of the Software is subject to the terms and conditions of the End User License Agreement.

Polycom reserves the right to audit your deployment to verify that you have sufficient licenses to match the number of devices being used.

Information in regards of License Part Numbers can be found here

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

Polycom Global Services

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 2 of 7
Cwebb
Advisor

Re: VVX 310 Lync cannot connect to Exchange UM 2013 for VM

Hi Steffen,

 

My phones are on 5.0.2.2756.

 

I have also opened a SR with Polycom support: 1-577237157.

 

Thank you,

Curtis

Message 3 of 7
Cwebb
Advisor

Re: VVX 310 Lync cannot connect to Exchange UM 2013 for VM

Update on this: We have now escalted to T3 and T4 from Polycom Engineering. This seems to be a big problem.

 

I'll be sure to update this thread in case any others run into this issue.

Message 4 of 7
Cwebb
Advisor

Re: VVX 310 Lync cannot connect to Exchange UM 2013 for VM

Another update. T4 has confirmed this as a known issue and are working on a solution that will involve some special phones loaded with dev only software. As soon as I find a cause I'll update this thread if possible.

Message 5 of 7
Cwebb
Advisor

Re: VVX 310 Lync cannot connect to Exchange UM 2013 for VM

We have tested special phones running the Dev only software and still have the same issue. We are awiating further logs analsys from Polycom Support. 

Message 6 of 7
Cwebb
Advisor

Re: VVX 310 Lync cannot connect to Exchange UM 2013 for VM

Polycom has provided another test build, and this time everything is working. We are awaiting a build that can be loaded onto production phones.

 

If anyone else has this issue, please contact Polycom support for a hot fix. 

Message 7 of 7