X50 Unable to Switch to Teams Mode

Occasional Visitor

X50 Unable to Switch to Teams Mode

Hello all,


A client recently asked us to migrate their Poly X30/X50 Zoom Rooms to Teams. All of the devices were purchased with native Zoom enabled so the upgrade process was a little funky. We had to downgrade all of them to the earliest release of the firmware (3.0.0) to remove their Zoom binding and switch them to Poly mode. Once there we had to upgrade to 3.3.1 with it still in Poly mode and then finally to 3.5.0 where we switched it to Teams mode. This worked on the X30's with only a few minor issues but when it came time to do the X50 we just can't seem to get it to switch out of Poly or Zoom mode. We followed the same exact steps on the X50 that we did with X30's but the option to switch the provider from Poly to anything else is grayed out and unavailable. The only time it switches away from Poly is if we perform a factory reset or use the web UI to upgrade from 3.3.1 to 3.5.0.


We thought this may have been caused by the X50 being registered in Lens where the others were not. However, we removed the X50 from Lens and tried the same process but got the same result. We are stuck and the client wants to move to Teams. Any advice or assistance would be greatly appreciated! See screenshot for Provider option being grayed out on the X50.

Beyond Conference
Valued Contributor

Re: X50 Unable to Switch to Teams Mode

Hi jschwartz, Have you tried to set the Provider in Lens to Teams?
Provisioning the factory reset X50 again to Lens where the Provider is set to Teams in Lens.

Provider setting in Lens.PNG


Message 2 of 6
Polycom Employee & Community Manager

Re: X50 Unable to Switch to Teams Mode

Hello @jschwartz ,


Welcome to the Poly Community.

If a device is purchased for a specific provider mode the provider can add them to our ZTO database and therefore prevent them from being used with any other provider. A bit like a mobile phone tied to a certain provider.


I can only ask you to contact Zoom so if they can remove the devices on their end.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier


If official support is required please check how to phone or open a case here

The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 3 of 6
Occasional Visitor

Re: X50 Unable to Switch to Teams Mode

Hi Beyond Conference,


I did not try that but I am wondering if the fact that we had purchased these as native Zoom appliances would have blocked it in Lens as well. Either way, another reload of the firmware and a factory reset once it was on version 3.5.0 did the trick and unlocked the Provider options for us.


I appreciate the response! 

Message 4 of 6
Occasional Visitor

Re: X50 Unable to Switch to Teams Mode

I just wanted to follow up on my post in case it would help somebody in the future.


We were able to get the Provider options to show again by doing the following sequence (I am not sure if this is the correct sequence but this worked for me):


1. Remove the device from Lens completely

2. Reload the 3.0.0 firmware using a USB

3. Switch the provider from Zoom to Poly

4. Load the 3.3.1 firmware using a USB

5. Load the 3.5.0 (or latest) firmware using the web UI

6. Factory Reset all settings (uncheck all boxes in the prompt)

7. Upon reset, the Provider options are available and able to switch to Teams.


Message 5 of 6
Occasional Visitor

Re: X50 Unable to Switch to Teams Mode

Hi Steffan,


Thank you for the feedback. If I run into this in the future, I will try contacting Zoom first to see if they can remove the provider lock on the devices. We were able to resolve it using the steps I outlined in my follow-up post. Thanks for the information!

Message 6 of 6