VSX 8000 Won't Power On

Occasional Visitor

VSX 8000 Won't Power On

I just came across an issue with a VSX 8000 that won't power on.  It has been working but was last used a few months ago.  As far as I know there haven't been any power surges or any spikes since it was last used.  When powering it on was attempted yesterday it was noticed that the power button was just blinking blue and then green.  It just alternates between the 2 repeatedly.  If you hold the power button they flash more rapidly, but the unit still doesn't boot.  You can also hear a slight clicking inside, almost as if the power supply is faulty.  I tried disconnecting everything and only connnected a monitor (to the vga port next to the LAN slot) and power but it was still the same.  Is there anything I can try to get this to boot again?

Message 1 of 2
Trusted Contributor

Re: VSX 8000 Won't Power On

Hi Dave.


Looks like you've already done the "isolate the power dependant peripherals" trick.

This is usually a mic cable that has been repeatedly rolled over by nutters on wheeled chairs

but not on this occasion.

Sounds like you need to RMA it.  Contact you local Polycom Service Centre or if you're UK/Europe

ping me the S# & I'll check if we're responsible for service.



Message 2 of 2