Logo

Unable to share content on X50 in Teams mode

SOLVED
Annika
Visitor

Unable to share content on X50 in Teams mode

When a HDMI cable is inserted to a laptop,when in a Teams meeting on X50, the Share button does not appear on the TC8. The Share button only appears on the TC8 when an external participant (not the MTR device) starts sharing some content, in the Teams meeting. And disappears again when the external participant stops sharing.

If someone tries to take over and share their content, by pushing the Share button on the TC8, then they get the message that no HDMI cable is connected even if it is. 

 

These are the current version installed on the X50 and the TC8;

FirmWare : 3.7.1.354025

Teams App: 1449/1.0.96.2021100102

 

Annika_0-1637767852311.png

Is this a configuration issue? Are we using the wrong versions of software / firmware?

Message 1 of 17
1 ACCEPTED SOLUTION

Accepted Solutions
SteffenBaierUK
Polycom Employee & Community Manager

Re: Unable to share content on X50 in Teams mode

Hello @Annika ,

 

the framework for 3rd party applications to use the HDMI port has always been there. Other Providers are successfully using this for ages.

 

Our partner Microsoft has been "slow" adding this feature to their Teams APK. I am not aware that there is already an APK providing this feature in GA so we can add the missing piece to our software.

 

It is a combined approach but Microsoft needs to deliver this APK to us 1st

 

@mshu  and myself are just volunteers and if you need an official answer please work with our support team

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections

View solution in original post

Message 6 of 17
16 REPLIES 16
mshu
Esteemed Contributor

Re: Unable to share content on X50 in Teams mode

Hi @ Annika,

 

HDMI Ingest is not yet supported in Studio X-series. It may be released in december, let´s wait and see...

Message 2 of 17
SteffenBaierUK
Polycom Employee & Community Manager

Re: Unable to share content on X50 in Teams mode

Hello @Annika ,

 

Welcome to the Poly Community. As outlined by @mshu the feature and functionality has not yet been activated by our Partner Microsoft. I believe this was in development and some of the verbiage I have seen this may now become active in some Teams Rings. The support for the feature to work needs to be added into our software to so please keep an eye on the release notes in case we release new software.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

 

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 3 of 17
Annika
Visitor

Re: Unable to share content on X50 in Teams mode

Hi @ mshu,

 

Thanks for taking the time to answer my question!

 

In the release notes for the Teams on Android App version - 1.0.96.2021051904, it states that select Teams Rooms devices now support projecting your screen via HDMI cable but that does not include Poly X50 yet according to your statement below, even if the Poly X50 Firmware 3.7.0 does support using HDMI cable to share content, is that correct?

 

And according to Poly's own "USER GUIDE 3.7.0 | September 2021 | 3725-86559-009A
Poly Partner Mode (G7500, Studio X70, Studio X50,and Studio X30) you can share content using a HDMI cable, on the X50 and X30.

 

So is it a new Microsoft App version that needs to include the content sharing using a HDMI cable that I need to wait for? Or is it Poly that needs to update their firmware?

Message 4 of 17
Annika
Visitor

Re: Unable to share content on X50 in Teams mode

Hi Steffen,

 

Sorry - I had not seen your reply when I posted an answer to @mshu.

 

So Microsoft must release/activate the functionality and then Poly has to do an update to the software before content sharing is available in the X50 / TC8, using a HDMI? Correct?

And there is no definite time when this may be released?

Message 5 of 17
SteffenBaierUK
Polycom Employee & Community Manager

Re: Unable to share content on X50 in Teams mode

Hello @Annika ,

 

the framework for 3rd party applications to use the HDMI port has always been there. Other Providers are successfully using this for ages.

 

Our partner Microsoft has been "slow" adding this feature to their Teams APK. I am not aware that there is already an APK providing this feature in GA so we can add the missing piece to our software.

 

It is a combined approach but Microsoft needs to deliver this APK to us 1st

 

@mshu  and myself are just volunteers and if you need an official answer please work with our support team

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 6 of 17
Dan Abato
Occasional Visitor

Re: Unable to share content on X50 in Teams mode

Microsoft released the Android Teams Room APK that allows for content sharing back in June (App version - 1.0.96.2021051904). What's taking so long for Poly to implement into their firmware? We were told by Poly September, then October, then November, now December. 

https://support.microsoft.com/en-us/office/what-s-new-in-microsoft-teams-devices-eabf4d81-acdd-4b23-...

Message 7 of 17
SteffenBaierUK
Polycom Employee & Community Manager

Re: Unable to share content on X50 in Teams mode

Hello @Dan Abato ,

 

If you require an official answer on this please open a support ticket. We are just volunteers here and cannot provide official answers for our Partner Microsoft and our software development team.

 

I can only state other partner modes have had the ability since day 1 so it's not just an updated Application.


Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 8 of 17
SteffenBaierUK
Polycom Employee & Community Manager

Re: Unable to share content on X50 in Teams mode

Hello @Annika , @Dan Abato  and @mshu 

 

We have released Poly OS 3.9.0 which has the option to support HDMI Ingest when using Microsoft Teams.

 

Please be aware of the following:

 

Our Partner Microsoft is rolling this feature out gradually so a specific Microsoft Teams tenant may not show this option as these updates are done not globally at the same time.

 

NOTE: The MTRoA does not support Audio via HDMI, unlike the MTRoW. Please work with our Partner Microsoft if you require this feature!

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 9 of 17

Re: Unable to share content on X50 in Teams mode

Hello @SteffenBaierUK, and others

 

I still can't share screen of my laptop in MS Teams mode, however it's connected to HDMI input of the codec (I tested it on both X30 and X50 units) and the codec is updated to 3.9.0-358026 firmware.

You stated that this option can be not available for my Teams account (at least I understand it in this way). Do you know perhaps how can I check whether this functionality works for my account?

 

Best regards,

 

Michal Moraszczyk

Message 10 of 17