TC8 Stuck on Successfully paired with StudioX50


TC8 Stuck on Successfully paired with StudioX50

I updated to 3.1.0 and it worked fine for the first few times I ran the device since the upgrade. I switched to Poly Video Mode to test USB Device Mode.


Now when I turn on my TC8 it gets stuck on Successfully paired with StudioX50 and doesn't move on from that screen. How do I get it to move on so I can turn USB Device Mode on again?


Edit: Changed to a Partner mode and back again and that seems to have fixed it for now, but this should not be necessary.

Message 1 of 2
Polycom Employee & Community Manager

Re: TC8 Stuck on Successfully paired with StudioX50

Hello @bmgr 


this would need to come into our support organization.


Best Regards


Steffen Baier


If official support is required please check how to phone or open a case here

The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓ SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 2 of 2