Logo

Poly X30 Update Problem

SOLVED
JohnnyA
Occasional Contributor

Poly X30 Update Problem

Hello,

I am trying to update a Poly X30 system for a client. However, when I am logged on to the web GUI for the X30 in the Device Management menu it is currently showing the error message of "The certificate is missing or invalid." in red under the Current Version. The Update button is greyed out and I can go no further.

I am attempting to update from the Polycom Support Site.

The current Poly VideoOS version of 3.13.0-368067 is installed.

I have tried restarting the device I have also tried switching it into Device mode from Teams mode and that has made no difference. Please can someone advise what I need to do to resolve this?

Thanks in advance.

Message 1 of 9
1 ACCEPTED SOLUTION

Accepted Solutions
cpe
Occasional Contributor

Re: Poly X30 Update Problem

I was able to solve it with incremental updates:

3.10 - 3.11 to 3.14

View solution in original post

Message 8 of 9
8 REPLIES 8
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly X30 Update Problem

Hello @JohnnyA ,

Your post ended up in the Spam Filter so it was moved here.

To release this one of us volunteers has to check this as this is an automatic process of the community software used to host this board. There is no need to raise this as abuse as this is a manual job one of the volunteers has to do.

For your actual issue, you need to update your Studio X and TC8 to 3.2.3 first. Then you can upgrade from there to the latest 3.14.1

Links to older versions are always included in the posts about new firmware. Example >here<


Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 2 of 9
JohnnyA
Occasional Contributor

Re: Poly X30 Update Problem

Hello Steffen,

Thank you for your reply.

I have tried following your advice and the link to the 3.2.3 firmware results in a 404 page error.

Can you provide an updated link to the 3.2.3 firmware please?

Thanks.


John.

Message 3 of 9
cpe
Occasional Contributor

Re: Poly X30 Update Problem

We have the same issue with a new deployed X50, can't update, certificate invalid or missing,

I tried to upgrade manually till the latest OS with no luck.

Message 4 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly X30 Update Problem

Hello @JohnnyA ,


@JohnnyA wrote:

Hello Steffen,

Thank you for your reply.

I have tried following your advice and the link to the 3.2.3 firmware results in a 404 page error.

Can you provide an updated link to the 3.2.3 firmware please?

Thanks.


John.


The link to the latest Software includes the download URLs when using a Custom Server.

- General Settings > Device Management > Change Download Update to Custom Server

Then use the URLs supplied in the mentioned post.

The best and quickest way forward is to contact our Support organization as the community is run by volunteers only.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 5 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: Poly X30 Update Problem

Hello @cpe


@cpe wrote:

We have the same issue with a new deployed X50, can't update, certificate invalid or missing,

I tried to upgrade manually till the latest OS with no luck.


Please see my reply to @JohnnyA

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 6 of 9
JohnnyA
Occasional Contributor

Re: Poly X30 Update Problem

Thank you Steffen.

I think if you had given the advice about the custom URLs in your first reply that would have been very helpful.

I will give it a try and report back. The volunteer help here is so often very good and can be faster than Poly support.

Message 7 of 9
cpe
Occasional Contributor

Re: Poly X30 Update Problem

I was able to solve it with incremental updates:

3.10 - 3.11 to 3.14

Message 8 of 9
JohnnyA
Occasional Contributor

Re: Poly X30 Update Problem

Thank you. This has now solved the problem for us.

Message 9 of 9