Poly TC8 stuck in loop trying to open Teams

Occasional Visitor

Poly TC8 stuck in loop trying to open Teams

We've got a Poly X50 + TC8 bundle for use with Teams.


I recently used the web interface of the X50 to upgrade to the latest software version of both X50 + TC8 due to the recent bug with Teams preventing the camera from working whilst in a call.


However now the TC8 is stuck in a loop opening the Teams app. I've attached a small video showing the problem.


I have tried switching the Provider back to Poly (which worked fine after the devices restarted) and back to Teams, but no luck. Both say "The software version is up-to-date."

X50 is on 3.9.1-360006

TC8 is on 3.9.0-210608


Please help us finally get a working X50 + TC8 for use with Teams!

Message 1 of 4
Polycom Employee & Community Manager

Re: Poly TC8 stuck in loop trying to open Teams

Hello @sc_uk ,


Welcome to the Poly Community.


I suggest you factory restore the TC8 and re-pair this. How to do this can be found >here<


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier



If official support is required please check how to phone or open a case here

The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 2 of 4
Dan Hemsø
Frequent Advisor

Re: Poly TC8 stuck in loop trying to open Teams



I have seen similar issue and it helped with an factory reset of the TC8.

So try it out as Steffen suggested 




Please remember to answer as "Accept as Solution" if you could use the help.
Message 3 of 4

Re: Poly TC8 stuck in loop trying to open Teams

Going back to this, It's best to wait to provision the TC8 until after you've provisioned the X50 first and it's done all of it's update.  


Current scenario - TC8 is on 3.9.0-210608 and the X50 is running latest 3.9.1-360006


Reset to Factory is the only way to remove this looping effect but only after all your updates and X50 is provisioned.  

Message 4 of 4