GoToRoom with Poly Studio X50 and TC8 : white screen

Steve_Roh
Occasional Visitor

GoToRoom with Poly Studio X50 and TC8 : white screen

Hi all, 

We are using GoToRoom with Poly Studio X50 and TC8 controller without problem since one year. Suddenly the screen of the TC8 controller keep white, and the Poly X50 indicates that it could'nt find the TC8.

If I change the provider as "Poly" or "Teams", the TC8 controller is working fine.

 

I've tried a restart and a factory reset on the TC8, the problem stay the same : white screen. The right menu on the TC8 is working fine. The screen become white only when reaching the "home" menu button.

 

Looking at the logs for TC8 show me this current error message : 

2022-01-25 08:28:53,229 WARN  [Binder:4698_5       ] InterAppMessageChannel - Couldn't unwrap message. Are codec and control running a compatible version?

2022-01-25 08:28:54,014 INFO  [okhttp-eventsource-stream-[]-0] EventSource - Waiting 3043377 milliseconds before reconnecting...

2022-01-25 08:28:54,015 ERROR [pool-4-thread-1     ] LaunchDarklyService - Failure

com.launchdarkly.sdk.android.LDFailure: Network error in stream connection

                at com.launchdarkly.sdk.android.StreamUpdateProcessor$1.onError(StreamUpdateProcessor.java:111)

                at com.launchdarkly.eventsource.AsyncEventHandler$5.run(AsyncEventHandler.java:70)

                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)

                at java.lang.Thread.run(Thread.java:764)

Caused by: javax.net.ssl.SSLHandshakeException: java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.

                at com.android.org.conscrypt.ConscryptFileDescriptorSocket.startHandshake(ConscryptFileDescriptorSocket.java:229)

                at okhttp3.internal.connection.RealConnection.connectTls(RealConnection.kt:379)

                at okhttp3.internal.connection.RealConnection.establishProtocol(RealConnection.kt:337)

                at okhttp3.internal.connection.RealConnection.connect(RealConnection.kt:209)

                at okhttp3.internal.connection.ExchangeFinder.findConnection(ExchangeFinder.kt:226)

                at okhttp3.internal.connection.ExchangeFinder.findHealthyConnection(ExchangeFinder.kt:106)

                at okhttp3.internal.connection.ExchangeFinder.find(ExchangeFinder.kt:74)

                at okhttp3.internal.connection.RealCall.initExchange$okhttp(RealCall.kt:255)

                at okhttp3.internal.connection.ConnectInterceptor.intercept(ConnectInterceptor.kt:32)

                at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:109)

                at okhttp3.internal.cache.CacheInterceptor.intercept(CacheInterceptor.kt:95)

                at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:109)

                at okhttp3.internal.http.BridgeInterceptor.intercept(BridgeInterceptor.kt:83)

                at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:109)

                at okhttp3.internal.http.RetryAndFollowUpInterceptor.intercept(RetryAndFollowUpInterceptor.kt:76)

                at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.kt:109)

                at okhttp3.internal.connection.RealCall.getResponseWithInterceptorChain$okhttp(RealCall.kt:201)

                at okhttp3.internal.connection.RealCall.execute(RealCall.kt:154)

                at com.launchdarkly.eventsource.EventSource.connect(EventSource.java:267)

                at com.launchdarkly.eventsource.EventSource.access$1300(EventSource.java:53)

                at com.launchdarkly.eventsource.EventSource$2.run(EventSource.java:156)

                ... 3 common frames omitted

Caused by: java.security.cert.CertificateException: java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.

                at com.android.org.conscrypt.TrustManagerImpl.verifyChain(TrustManagerImpl.java:661)

                at com.android.org.conscrypt.TrustManagerImpl.checkTrustedRecursive(TrustManagerImpl.java:539)

                at com.android.org.conscrypt.TrustManagerImpl.checkTrustedRecursive(TrustManagerImpl.java:605)

                at com.android.org.conscrypt.TrustManagerImpl.checkTrustedRecursive(TrustManagerImpl.java:605)

                at com.android.org.conscrypt.TrustManagerImpl.checkTrusted(TrustManagerImpl.java:495)

                at com.android.org.conscrypt.TrustManagerImpl.checkTrusted(TrustManagerImpl.java:418)

                at com.android.org.conscrypt.TrustManagerImpl.getTrustedChainForServer(TrustManagerImpl.java:339)

                at android.security.net.config.NetworkSecurityTrustManager.checkServerTrusted(NetworkSecurityTrustManager.java:94)

                at android.security.net.config.RootTrustManager.checkServerTrusted(RootTrustManager.java:88)

                at com.android.org.conscrypt.Platform.checkServerTrusted(Platform.java:208)

                at com.android.org.conscrypt.ConscryptFileDescriptorSocket.verifyCertificateChain(ConscryptFileDescriptorSocket.java:404)

                at com.android.org.conscrypt.NativeCrypto.SSL_do_handshake(Native Method)

                at com.android.org.conscrypt.NativeSsl.doHandshake(NativeSsl.java:375)

                at com.android.org.conscrypt.ConscryptFileDescriptorSocket.startHandshake(ConscryptFileDescriptorSocket.java:224)

                ... 23 common frames omitted

Caused by: java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.

                ... 37 common frames omitted

2022-01-25 08:28:54,017 INFO  [pool-4-thread-1     ] LaunchDarklyService - Status: Mode: STREAMING

Success at: Tue Jan 25 07:38:49 GMT+01:00 2022

Failure at: Tue Jan 25 08:28:54 GMT+01:00 2022

Failure type: NETWORK_FAILURE

2022-01-25 08:28:55,932 WARN  [Binder:4698_5       ] InterAppMessageChannel - Couldn't unwrap message. Are codec and control running a compatible version?

Thanks for your help, 

Steve

Message 1 of 9
8 REPLIES 8
Steve_Roh
Occasional Visitor

Re: GoToRoom with Poly Studio X50 and TC8 : white screen

I forgot some informations : 

Current version of POLY TC8 : 3.9.0-210608

Current version of POLY X50 : 3.9.1-360006

I don't have the exact start date of the problem, but about the 20th of January 2022.

 

Thanks again for your help

 

Steve

Message 2 of 9
Steve_Roh
Occasional Visitor

Re: GoToRoom with Poly Studio X50 and TC8 : white screen

Me again, 

furthere informations :

Poly X50 version : 3.9.1-360006

Poly TC8 version : 3.9.0-210608

 

The problem has been reported last friday, 21th of January 2022. I see that there was an update on Thursday. Could it be the source of the problem as we have set automatic updates ?

Is it possible to go back to a previous version ?

 

Thanks again, 

Steve

Message 3 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: GoToRoom with Poly Studio X50 and TC8 : white screen

Hello @Steve_Roh ,

 

Welcome to the Poly Community.


Downgrade via General Settings > Download Update From Customer Server URL

https://swupdate.lens.poly.com/polyos/3.9.0/358026

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

 

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 4 of 9
Steve_Roh
Occasional Visitor

Re: GoToRoom with Poly Studio X50 and TC8 : white screen

Hi Steffen, 

thanks for your quick answer !

I updated (downgraded) the Poly X50, then make a factory reset on the TC8 but the problem is still there...
Actual version :

X50 : 3.9.0-358026
TC8 : 3.9.0-210608

I join a video of the problem

Thanks

Steve

Message 5 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: GoToRoom with Poly Studio X50 and TC8 : white screen

Hello @Steve_Roh ,

 

The next step is to contact our support organization. Other volunteers are welcome to reply but if you need support this is the way to go.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

 

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 6 of 9
Steve_Roh
Occasional Visitor

Re: GoToRoom with Poly Studio X50 and TC8 : white screen

Hi, 

after several downgrade, we see that the TC8 stay at the same version !

Do you know how to downgrade the TC8 too ?

 

Thanks & Regards, 

 

Steve

Message 7 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: GoToRoom with Poly Studio X50 and TC8 : white screen

Hello @Steve_Roh ,

 

Welcome back to the Poly Community.

 

We do not know what you have done aka followed the factory advice and/or what version is there on now. Please follow this up with our support team as advised.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

 

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 8 of 9
SteffenBaierUK
Polycom Employee & Community Manager

Re: GoToRoom with Poly Studio X50 and TC8 : white screen

Hello @Steve_Roh 

 

Welcome back to the Poly Community.

 

We have just released PolyOS 3.10.0

 

The above has a fix for the to us known issue with the partner application on TC8 being unable to start / update

 

If you still find an issue please work with our Support Organisation.

 

Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

 

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 9 of 9