Logo

Blackwire 3220 mute button disabled in Microsoft Teams meetings

kevinmcl
Occasional Visitor

Blackwire 3220 mute button disabled in Microsoft Teams meetings

My previous Plantronics headset worked for years. I would enter a Teams meeting, enable the Teams microphone icon, and then use the mic button on the headset control to instantly mute and unmute myself when needed. This was with corporate Windows 7 and then Windows 10.  Several months ago (in 2022) the button stopped working as soon as I entered a Teams meeting. It still works fine in Skype meetings.  I thought it might be age and decrepitude, so I got a new Blackwire 3220.   It has the same problem. This is VERY inconvenient compared to previously available functionality.  The device is updated to firmware v.222. 

Teams has no relevant setting.
Windows Settings sees the device, but has no setting that addresses the behavior.
I downloaded and installed Plantronics Hub software, which obligingly tells me, for each category, that there are no settings to modify. 

The corporate laptop gets weekly Windows updates.

QUESTION:   How do I get the mute/unmute microphone button on the headset control to work properly within MS Teams in Windows 10 on the corporate laptop?

Message 1 of 1