Logo

8225 Blackwire with RingCentral

Phoneguy@Medcor
Occasional Visitor

8225 Blackwire with RingCentral

My Company has almost 200 RingCentral NICE incontact agents using the 8225 Blackwire headsets. We are having issues with lots of agents reporting dead air calls. When reviewing the call recordings both sides are heard in the recording so this tells me its an issue on the Agents end. Has anyone else experienced these issues and found a resolution? Things I have tried so far. 

1) Updated firm ware on headset.

2) PCs updated.

3) Plantronics Managed hub setting Softphone to Cisco IP Communicator and disabling Teams.

4) Headset set as default sound device.

5) RingCentral sound set as Same as system default. 

6) Registry entries added : 

IntensiveWakeUpThrottlingEnabled    value 0    RegDword
WindowOcclusionEnabled     value 0    RegDword

HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\GOOGLE\CHROME
HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\MICROSOFT\EDGE

7) Turn off Headset control in RC.

Using Latest version of RC Phone App.

9) Turned off Power Management for USB .

 

Is there anything I am missing? Any help is much appreciated

Message 1 of 2
1 REPLY 1
Poly Mukesh
Polycom Employee & Moderator

Re: 8225 Blackwire with RingCentral

Hello  Phoneguy@Medcor 

 

Welcome to the Poly Community !!

 

This requires further investigation. Hence we would suggest you to open a support ticket with Poly.

 

 

 

 

Best Regards,
Mukesh Kumar

Please ensure you always check the FAQ's.

Please remember, if you see a post that helped you, and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer. Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.

Message 2 of 2