Trio Calendaring works directly with 365 but not with OTD

SOLVED
Adam in DC
Trusted Contributor

Trio Calendaring works directly with 365 but not with OTD

In this case, Trio 8500 7.1.1.0731

https://outlook.office365.com/EWS/Exchange.asmx

username@domain and pwd - works every time.  

But, if I change the url to:

https://otd.plcm.vc/ews/exchange.asmx

and then user the otd generated username and password of  scrambled@otd.plcm.vc and pwd it never works.  

On the OTD website, the device is listed as unreachable. - even though the calendar connectivity test works perfectly.  At the same time, every Group Series I have using OTD works perfectly.  

On the Trio it self, it lists EWS as deployed, but not sync'd.  

I'm fine with continuing to use native Trio calendaring, but would really like to be able to get OTD to work to compare differences in how it parses info to create the join button.  

I assume there's something obvious I'm missing, but not sure what it is.  Suggestions? 

 

Tags (3)
Message 1 of 6
1 ACCEPTED SOLUTION

Accepted Solutions
Adam in DC
Trusted Contributor

Re: Trio Calendaring works directly with 365 but not with OTD

I had a great call with OTD support today and we figured out the issue.

 

The Trio has a setting that can only be turned on (to my knowledge) by adding this cfg file.  The config turns on Basic Authentication on the Trio.  But it's not Basic Authentication to Exchange (which Microsoft is removing) it's Basic Authentication to the OTD website.  It was that simple.  

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Application SIP Cedar 5.9.0.11421 09-Jul-19 13:55 -->
<!-- Created 05-09-2019 11:53 -->
<!-- Base profile Lync -->
<PHONE_CONFIG>
<WEB
feature.exchange.allowBasicAuth="1"
/>
</PHONE_CONFIG>

View solution in original post

Message 4 of 6
5 REPLIES 5
Seanster
Occasional Visitor

Re: Trio Calendaring works directly with 365 but not with OTD

I have the exact same problem.  When the device is in that state of unreachable, i reboot the Trio and it re-establishes a connection.  It will remain that way for a period of time before disconnecting again.

 

Still haven't found a resolve to it.   Let me know if you do.

Message 2 of 6
Adam in DC
Trusted Contributor

Re: Trio Calendaring works directly with 365 but not with OTD

I haven't bothered to try since the native processing usually does the job.  But I might put in a ticket with my local distributor to get some help.  

 

There's also the possibility that since the 8500/8800s are at or near end of support - I might not get an answer.  

Message 3 of 6
Adam in DC
Trusted Contributor

Re: Trio Calendaring works directly with 365 but not with OTD

I had a great call with OTD support today and we figured out the issue.

 

The Trio has a setting that can only be turned on (to my knowledge) by adding this cfg file.  The config turns on Basic Authentication on the Trio.  But it's not Basic Authentication to Exchange (which Microsoft is removing) it's Basic Authentication to the OTD website.  It was that simple.  

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Application SIP Cedar 5.9.0.11421 09-Jul-19 13:55 -->
<!-- Created 05-09-2019 11:53 -->
<!-- Base profile Lync -->
<PHONE_CONFIG>
<WEB
feature.exchange.allowBasicAuth="1"
/>
</PHONE_CONFIG>
Message 4 of 6
SteffenBaierUK
Polycom Employee & Community Manager

Re: Trio Calendaring works directly with 365 but not with OTD

Hello @Adam in DC ,

 

Welcome back to the Poly Community.


This was stuck in our spam filter and I have released it.

 

Best Regards

Steffen Baier

----------------

If official support is required please check how to phone or open a case here

----------------
The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's
Message 5 of 6
Adam in DC
Trusted Contributor

Re: Trio Calendaring works directly with 365 but not with OTD

Disappointed that I have to open this topic up again.  

 

So, our DC office is opening up on March 1.  I was in the office today to do some prep - and noticed that some of our Trio/Visual+ combos were doing the black screen thing - so I rebooted them.  Then I noticed that non of the trios - all 4 - were connected to the resource calendars in Exchange online.  

 

So - I tried retyping the password - no change.  No EWS Sync.  

 

The only Trio I had working was my Spare test Trio - the one that I had connected to OTD rather than native Trio to EWS.  To me this mean that the OTD method simply was more sturdy than the native method.  Why would all 4 stop working by the OTD one still work?  

 

So - I added the cfg file in this thread to all 4 machines - added them to OTD - and every single one picked up the calendars again.  

 

That's the good news.

 

The bad news is that test appointments in all rooms - for Teams - failed.  Joining the call resulted in "the number you have dialed" error messages.  

 

Joining the calls for Zoom, however worked.  

 

I have seen this before - it's some kind of cfg error where parsing the Teams info isn't working right - likely because I added the basic auth piece to get OTD to work.  

 

On a positive note - my Teams Lobby button still works - so users can still join Teams calls if they have the Meeting number handy.  

 

Needless to say, I've put in a ticket with my local integrator - who will hopefully and quickly- connect me with their reseller - ScanSource.  

 

There's a lot I can do remotely - including web into the Trios - but testing a call requires being onsite. 

 

Any tips on how to edit the cfg file in this situation? 

Tags (5)
Message 6 of 6