Poly Lens won't push configuration to Poly Studio USB

Occasional Visitor

Poly Lens won't push configuration to Poly Studio USB

I've been following Jan's great YouTube videos in connecting our G40-T's Studio USB into Lens and remotely manage without logging into the Windows MTR system:




The problem I'm having is there seems to be inherited values I previously manually set into favorites via Polycom Companion that are overriding anything I set in device policy in Poly Lens (from the cloud) and try to push out.


I've tried multiple factory resets from the Poly Lens desktop app and have even deleted all 4 favorites previously set leaving only Sandbox. I've also tried deleted the device from Poly Lens (cloud) multiple times. Each time I readd it after registering via Poly Lens desktop on the MTR all settings come back like they were never deleted.


I think Poly Lens is supposed to create a new favorite called IT-Managed with all settings I pushed out being greyed out in the Poly Lens desktop app, but it's not working.


Only thing I can think of is to try the paperclip factory reset, delete the device from Poly Lens cloud, and retry in a day or two to give the cloud some time to delete my old device...and then retry again.


I have a different brand new G40-T for another room that I'll be setting up today and will go straight to a Poly Lens (cloud) provisioned device with no previous settings on the device (true greenfield), so I will see how that does today.


If anyone else has experience with converting Studio USBs out in the field to use Poly Lens cloud provisioned, I'd be appreciative for any tips to provide clues on what I'm doing wrong.



Message 1 of 3
Poly Rahul
Polycom Employee & Moderator

Re: Poly Lens won't push configuration to Poly Studio USB

Hello @SpinningRust 


Welcome back to Poly community !


This requires further investigation. Hence we would suggest you to open a support ticket with Poly.







Best Regards,
Rahul Nautiyal

Please ensure you always check the FAQ's.

Please remember, if you see a post that helped you, and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer. Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.

Message 2 of 3
Occasional Visitor

Re: Poly Lens won't push configuration to Poly Studio USB

Ok, I will look into that. Just wanted to provide some feedback, we have setup 2 other brand new out of the box devices and Poly lens will not push configuration to either of them.


Also, with our Studio X30/X50 devices, there doesn't seem to be a way to tie in the provisioning server address like I see in the documentation from Lens. We have resorted to using the PIN method which doesn't allow us to manage as much of the config except through the XML.

Message 3 of 3