SoundStation Duo host name registration


SoundStation Duo host name registration



we are using two SoundStation Duo in the company,

in PSTN only mode, Ethernet connection is used just

for provision/network time/LDAP connection.


Software version is 4.0.15, phones are currently with fixed IPv4 addresses.

I have tried to use DHCP, but found no way to have the host names

(soundstationduo455conferenceroom, soundstationduo454mensa) resolved by the DNS(=active directory)

My opinion is that the name can be passed by DHCP option 12.

I did not record a trace yet. Is this the right way how it supposed work?


I also noted that in the web interface, Option Settings/PSTN shows

"(error loading page). The document requested was not found on this server."

While the SIP settings pages show up.

Message 1 of 4
Polycom Employee & Community Manager

Re: SoundStation Duo host name registration

Hello @V.Kannegieser ,


Welcome to the Poly Community.


What browser do you see the error with and can you attach a screen capture?


In regards to the hostname the FAQ section over in the VoIP community has this:


Aug 10, 2016 Question:Can I change the Hostname of my Poly phone?

Explanation:Please check => here <=


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier



If official support is required please check how to phone or open a case here

The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.


⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓SIGNATURE ⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓⇓
Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
Please also ensure you always check the VoIP , Video Endpoint , Microsoft Voice , PSTN or other FAQ's in the different sections
Message 2 of 4

Re: SoundStation Duo host name registration

Hello Mr. Baier,


regarding the Web configuration interface PSTN option,

the browser is Pale Moon, tried other browser (but no chrome),

same effect, browser debug tools show error 404 for http://<ip>/pstnConf.htm.


navigating to the PSTN menu setting 

error message after selection 


For the DNS, the names are long, but less than 63 chars, only have letters and hyphens.

I will try to move the phone to my desk in the evening and have a look with Wireshark.

Message 3 of 4

Re: SoundStation Duo host name registration

The phone sends DHCP option 12 as entered, tried both full and short name.


Frame 1631: 510 bytes on wire (4080 bits), 510 bytes captured (4080 bits) on interface lan_marelli, id 0
Ethernet II, Src: Polycom_ea:27:77 (00:04:f2:ea:27:77), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src:, Dst:
User Datagram Protocol, Src Port: 68, Dst Port: 67
Dynamic Host Configuration Protocol (Request)
    Message type: Boot Request (1)
    Hardware type: Ethernet (0x01)
    Hardware address length: 6
    Hops: 0
    Transaction ID: 0xe59af441
    Seconds elapsed: 0
    Bootp flags: 0x0000 (Unicast)
    Client IP address:
    Your (client) IP address:
    Next server IP address:
    Relay agent IP address:
    Client MAC address: Polycom_ea:27:77 (00:04:f2:ea:27:77)
    Client hardware address padding: 00000000000000000000
    Server host name not given
    Boot file name not given
    Magic cookie: DHCP
    Option: (53) DHCP Message Type (Request)
        Length: 1
        DHCP: Request (3)
    Option: (50) Requested IP Address (
        Length: 4
        Requested IP Address:
    Option: (54) DHCP Server Identifier (
        Length: 4
        DHCP Server Identifier:
    Option: (57) Maximum DHCP Message Size
        Length: 2
        Maximum DHCP Message Size: 1492
    Option: (55) Parameter Request List
        Length: 16
        Parameter Request List Item: (1) Subnet Mask
        Parameter Request List Item: (28) Broadcast Address
        Parameter Request List Item: (160) Unassigned (ex DHCP Captive-Portal)
        Parameter Request List Item: (66) TFTP Server Name
        Parameter Request List Item: (43) Vendor-Specific Information
        Parameter Request List Item: (3) Router
        Parameter Request List Item: (4) Time Server
        Parameter Request List Item: (42) Network Time Protocol Servers
        Parameter Request List Item: (2) Time Offset
        Parameter Request List Item: (6) Domain Name Server
        Parameter Request List Item: (15) Domain Name
        Parameter Request List Item: (7) Log Server
        Parameter Request List Item: (128) DOCSIS full security server IP [TODO]
        Parameter Request List Item: (144) Geospatial Location [TODO:RFC6225]
        Parameter Request List Item: (157) Leasequery Data Source
        Parameter Request List Item: (191) Unassigned
    Option: (12) Host Name
        Length: 53
        Host Name: soundstationduo455conferenceroom.mmemea.marelliad.net
    Option: (60) Vendor class identifier
        Length: 13
        Vendor class identifier: Polycom-SSDuo
    Option: (125) V-I Vendor-specific Information
        Length: 118
        Enterprise: Polycom, Inc. (13885)
            Length: 113
            Option 125 Suboption: 1
                Length: 7
                Data: 506f6c79636f6d
            Option 125 Suboption: 2
                Length: 19
                Data: 536f756e6453746174696f6e2d53535f44756f
            Option 125 Suboption: 3
                Length: 16
                Data: 333131312d31393030302d3030312c31
            Option 125 Suboption: 4
                Length: 31
                Data: 5349502f342e302e31352e313030392f30372d4665622d32302031343a3336
            Option 125 Suboption: 5
                Length: 30
                Data: 55502f352e302e31352e303734312f30352d4665622d32302032303a3138
    Option: (255) End
        Option End: 255


Does not get resolved by DNS(active directory), but then this is likely a DHCP/AD server problem, not a phone configuration problem.


best reagards.

Message 4 of 4