Updating MDA220 Firmware

MrPhoneGuy
Occasional Visitor

Updating MDA220 Firmware

I’ve been trying to update the firmware of the MDA220 units through the Hub software but it doesn’t seem to work. It only recognizes the BT600 dongle, not the actual MDA220 USB switcher unit.


It is connected USB to the computer, what else is there I need to do?

Message 1 of 3
2 REPLIES 2
Poly Farhan
Polycom Employee & Community Manager

Re: Updating MDA220 Firmware

Hello @MrPhoneGuy 

 

Welcome back to the Poly community. 

 

Could you please plug a wall power adapter into the MDA220 USB and then proceed to update your firmware via our Poly software?

 

Regards,

Farhan Siddiqui
----------------

The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Message 2 of 3
MrPhoneGuy
Occasional Visitor

Re: Updating MDA220 Firmware

Ok - I finally got the MDA220 to detect itself through Poly Lens.

 

However when I initiate the update - it gets stuck at 51% - and fails repeatedly.

 

Afterwards the MDA220 hub is showing a red light on the computer button.

 

How do I fix this so I can get it working again?

 

Poly Lens nor the Hub software now does not detect the MDA220...

Message 3 of 3