Reverse BT600 Firmware Update

Reverse BT600 Firmware Update

Yesterday I updated the firmware on my BT600 to v.2120.  My computer recognizes it as a sound device but when I connect to Microsoft Teams, only the speaker portion of my Voyager 5200 works, it does not recognize the mic.  I've noticed that the dongle flashes blue as if it is active on a Teams call but no calls are active.

Is there a way to downgrade the BT600 to the previous firmware version or even do a factory reset? Everything was working fine prior to the update.

Message 1 of 2
1 REPLY 1
Poly Farhan
Polycom Employee & Community Manager

Re: Reverse BT600 Firmware Update

Hello cgibilaro@gmail.com 

 

Welcome back to the Poly community. 

 

For Firmware Updates & recovery, please contact our support team by visiting this link.

 

Regards,   

Farhan Siddiqui
----------------

The title Poly Employee & Community Manager is a community setting and does not reflect my role. I am just a simple volunteer in the community like everybody else. All posts and words are my own & do not represent the views of Employer.

----------------

Notice: This community forum is not an official Poly support resource, thus responses from Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge. If you need immediate and/or official assistance please open a service ticket through your proper support channels.
Please also ensure you always check the VoIP , Video Endpoint , Skype for Business , PSTN or RPM FAQ's

Message 2 of 2