Audio degredation on Focus BT headset in games when mic is enabled

-Ron-
Occasional Visitor

Audio degredation on Focus BT headset in games when mic is enabled

Dear reader,

I am experiencing bad audio (mono sound with some weird echoing) in games when the microphone of my focus UC 2 headset with BT700 has been enabled. (also having this issue using my older Focus UC with BT600)

I am using windows 11 and sound quality is great when listening music (like spotify) when the microphone is enabled and active but when starting a game audio gets REALLY bad.

When disabling the microphone device to be active for apps the sound is fine in games.

Is there a fix for this as I want to be able to use the microphone in game to chat and have decent audio.

Message 1 of 2
1 REPLY 1
Poly Mukesh
Polycom Employee & Moderator

Re: Audio degredation on Focus BT headset in games when mic is enabled

Hello @-Ron- 

 

Welcome to Poly Community !!

 

Please make sure your headset is updated to the latest firmware. Additionally, you can try a factory restore on the device and see if it helps. 

 

You may open a support ticket with Poly in the event that the issue persists.  

 

Best Regards,
Mukesh Kumar

Please ensure you always check the FAQ's.

Please remember, if you see a post that helped you, and it answers your question, please mark it as an "Accept as Solution".

This forum reply or post is based upon my personal experience and does not reflect the opinion or view of my employer. Poly employee participation within this community is not mandatory and any post or FAQ article provided by myself is done either during my working hours or outside working hours, in my private time, and may be answered on weekends, bank holidays or personal holidays.

Message 2 of 2